re = /.*http:.*/
str = '//this line should be ignored http://foo.com
NSString *url = @"http://foo.com"; //this line should show up as a result'
# Print the match result
str.match(re) do |match|
puts match.to_s
end