const regex = /^[-+]?[0-9]*\.?[0-9]+\b$/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[-+]?[0-9]*\\.?[0-9]+\\b$', 'gi')
const str = `2030230.12123 sadadasdas`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);