re = /^[-+]?[0-9]*\.?[0-9]+\b$/i
str = '2030230.12123 sadadasdas'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result