$re = '/^[-+]?[0-9]*\.?[0-9]+\b$/i';
$str = '2030230.12123 sadadasdas';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;