$re = '/translate\(
([\'"])
.+?
\1
\)/x';
$str = 'translate("some text here")
translate(\'some text here\')
translate(\'"some text here..."\')
translate(\'some \\\' text here\')';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);