re = /translate\(
(['"])
.+?
\1
\)/x
str = 'translate("some text here")
translate(\'some text here\')
translate(\'"some text here..."\')
translate(\'some \\\' text here\')'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end