package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)((?P<Days>\d{0,2})d\s*)?((?P<Hours>\d{0,2})h\s*)?((?P<Mins>\d{0,2})m)?`)
var str = `1d 12m
43m
1d 10h 20m
20h 10m
5h
2d`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}