re = /((?P<Days>\d{0,2})d\s*)?((?P<Hours>\d{0,2})h\s*)?((?P<Mins>\d{0,2})m)?/m
str = '1d 12m
43m
1d 10h 20m
20h 10m
5h
2d'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end