import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?P<Days>\\d{0,2})d\\s*)?((?P<Hours>\\d{0,2})h\\s*)?((?P<Mins>\\d{0,2})m)?";
final String string = "1d 12m\n"
+ "43m\n"
+ "1d 10h 20m\n"
+ "20h 10m\n"
+ "5h\n"
+ "2d";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}