#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)\[.*IMG.*[^\]]\]"
Local $sString = "[ IMG ] http://test.test/test.jpg [ /IMG] sdfsgeg" & @CRLF & _
"ewye [IMG]http://test.test/test.jpg [/ IMG]ertw" & @CRLF & _
"rtwertewt [IMG]http://test.test/test.jpg[/IMG ]sdfweqw" & @CRLF & _
"" & @CRLF & _
"erqwerwq [ img ] http://test.test/test.jpg[ / IMG ]jnljlkjljlkj"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")