$re = '/\[.*IMG.*[^\]]\]/i';
$str = '[ IMG ] http://test.test/test.jpg [ /IMG] sdfsgeg
ewye [IMG]http://test.test/test.jpg [/ IMG]ertw
rtwertewt [IMG]http://test.test/test.jpg[/IMG ]sdfweqw
erqwerwq [ img ] http://test.test/test.jpg[ / IMG ]jnljlkjljlkj';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);