// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)\[.*IMG.*[^\]]\]").unwrap();
let string = "[ IMG ] http://test.test/test.jpg [ /IMG] sdfsgeg
ewye [IMG]http://test.test/test.jpg [/ IMG]ertw
rtwertewt [IMG]http://test.test/test.jpg[/IMG ]sdfweqw
erqwerwq [ img ] http://test.test/test.jpg[ / IMG ]jnljlkjljlkj";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}