using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=\D*\d\D*$)[0-9-](?:,[0-9-]){4}$";
string input = @"9,-,-,-,-
-,-,-,-,9
-,-,2,-,-
-,-,-,9,-
-,2,-,9,-
-,-,-,9,-,-";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}