$re = '/^(?=\D*\d\D*$)[0-9-](?:,[0-9-]){4}$/m';
$str = '9,-,-,-,-
-,-,-,-,9
-,-,2,-,-
-,-,-,9,-
-,2,-,9,-
-,-,-,9,-,-';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);