re = /^(?=\D*\d\D*$)[0-9-](?:,[0-9-]){4}$/m
str = '9,-,-,-,-
-,-,-,-,9
-,-,2,-,-
-,-,-,9,-
-,2,-,9,-
-,-,-,9,-,-'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end