#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^# -+(?:\n# .*)*\n# -+$\n?"
Local $sString = "# ---------------------------------------------------------------------------------------------------------------------" & @CRLF & _
"# MODULE PARAMETERS" & @CRLF & _
"# These are the variables we have to pass in to use the module specified in the terragrunt configuration above" & @CRLF & _
"# ---------------------------------------------------------------------------------------------------------------------" & @CRLF & _
" " & @CRLF & _
"Text goes here" & @CRLF & _
"" & @CRLF & _
"# ---------------------------------------------------------------------------------------------------------------------" & @CRLF & _
"# MODULE PARAMETERS" & @CRLF & _
"# These are the variables we have to pass in to use the module specified in the terragrunt configuration above" & @CRLF & _
"# ---------------------------------------------------------------------------------------------------------------------" & @CRLF & _
"" & @CRLF & _
"and more" & @CRLF & _
"" & @CRLF & _
"# ---------------------------------------------------------------------------------------------------------------------" & @CRLF & _
"# MODULE PARAMETERS" & @CRLF & _
"# These are the variables we have to pass in to use the module specified in the terragrunt configuration above" & @CRLF & _
"# ---------------------------------------------------------------------------------------------------------------------"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")