import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^# -+(?:\\n# .*)*\\n# -+$\\n?";
final String string = "# ---------------------------------------------------------------------------------------------------------------------\n"
+ "# MODULE PARAMETERS\n"
+ "# These are the variables we have to pass in to use the module specified in the terragrunt configuration above\n"
+ "# ---------------------------------------------------------------------------------------------------------------------\n"
+ " \n"
+ "Text goes here\n\n"
+ "# ---------------------------------------------------------------------------------------------------------------------\n"
+ "# MODULE PARAMETERS\n"
+ "# These are the variables we have to pass in to use the module specified in the terragrunt configuration above\n"
+ "# ---------------------------------------------------------------------------------------------------------------------\n\n"
+ "and more\n\n"
+ "# ---------------------------------------------------------------------------------------------------------------------\n"
+ "# MODULE PARAMETERS\n"
+ "# These are the variables we have to pass in to use the module specified in the terragrunt configuration above\n"
+ "# ---------------------------------------------------------------------------------------------------------------------";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}