package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([^=]+)=([^;]+);?`)
var str = `AF_ESP=0.00546;AF_EXAC=0.00165;AF_TGP=0.00619`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}