$re = '/([^=]+)=([^;]+);?/m';
$str = 'AF_ESP=0.00546;AF_EXAC=0.00165;AF_TGP=0.00619';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);