// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([^=]+)=([^;]+);?").unwrap();
let string = "AF_ESP=0.00546;AF_EXAC=0.00165;AF_TGP=0.00619";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}