using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?:^|-|\s)(large)(?:-|$|\s))";
string input = @"large-xlarge small-medium-large medium-large-xlarge
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}