re = /((?:^|-|\s)(large)(?:-|$|\s))/
str = 'large-xlarge small-medium-large medium-large-xlarge
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end