$re = '/((?:^|-|\s)(large)(?:-|$|\s))/';
$str = 'large-xlarge small-medium-large medium-large-xlarge
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);