using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[A-Za-zÀ-ú]+ ?\-?[A-Za-zÀ-ú]+";
string input = @"téstê téstê téstê téstê-téstê";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}