using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"i\+\+|\+\+i";
string input = @"This is what i++ is do ++i and in i I dim ++ +";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}