$re = '/i\+\+|\+\+i/';
$str = 'This is what i++ is do ++i and in i I dim ++ +';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);