package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`i\+\+|\+\+i`)
var str = `This is what i++ is do ++i and in i I dim ++ +`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}