#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ""(?:[^"]|"")*""
Local $sString = ""Lorem ipsum dolor sit amet, " & @CRLF & _
" consectetur adipisicing elit, sed do eiusmod" & @CRLF & _
" tempor incididunt ut labore et dolore magna " & @CRLF & _
" aliqua. Ut ""enim ad"" minim veniam," & @CRLF & _
" quis nostrud exercitation ullamco laboris nisi " & @CRLF & _
" ut aliquip ex ea commodo" & @CRLF & _
" consequat. Duis aute irure dolor in reprehenderit in voluptate velit esse" & @CRLF & _
" cillum dolore eu fugiat ""nulla pariatu"""" & @CRLF & _
""ex ea commodo" & @CRLF & _
" consequat. Duis aute irure ""dolor in"" reprehenderit " & @CRLF & _
" in voluptate velit esse" & @CRLF & _
" cillum dolore eu fugiat nulla pariatur. " & @CRLF & _
" Excepteur sint occaecat cupidatat non" & @CRLF & _
" proident, sunt in culpa qui officia deserunt " & @CRLF & _
" mollit anim id est laborum.""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")