import re
regex = re.compile(r"\"(?:[^\"]|\"\")*\"")
test_str = ("\"Lorem ipsum dolor sit amet, \n"
" consectetur adipisicing elit, sed do eiusmod\n"
" tempor incididunt ut labore et dolore magna \n"
" aliqua. Ut \"\"enim ad\"\" minim veniam,\n"
" quis nostrud exercitation ullamco laboris nisi \n"
" ut aliquip ex ea commodo\n"
" consequat. Duis aute irure dolor in reprehenderit in voluptate velit esse\n"
" cillum dolore eu fugiat \"\"nulla pariatu\"\"\"\n"
"\"ex ea commodo\n"
" consequat. Duis aute irure \"\"dolor in\"\" reprehenderit \n"
" in voluptate velit esse\n"
" cillum dolore eu fugiat nulla pariatur. \n"
" Excepteur sint occaecat cupidatat non\n"
" proident, sunt in culpa qui officia deserunt \n"
" mollit anim id est laborum.\"")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")