import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"(?:[^\"]|\"\")*\"";
final String string = "\"Lorem ipsum dolor sit amet, \n"
+ " consectetur adipisicing elit, sed do eiusmod\n"
+ " tempor incididunt ut labore et dolore magna \n"
+ " aliqua. Ut \"\"enim ad\"\" minim veniam,\n"
+ " quis nostrud exercitation ullamco laboris nisi \n"
+ " ut aliquip ex ea commodo\n"
+ " consequat. Duis aute irure dolor in reprehenderit in voluptate velit esse\n"
+ " cillum dolore eu fugiat \"\"nulla pariatu\"\"\"\n"
+ "\"ex ea commodo\n"
+ " consequat. Duis aute irure \"\"dolor in\"\" reprehenderit \n"
+ " in voluptate velit esse\n"
+ " cillum dolore eu fugiat nulla pariatur. \n"
+ " Excepteur sint occaecat cupidatat non\n"
+ " proident, sunt in culpa qui officia deserunt \n"
+ " mollit anim id est laborum.\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}