#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^[a-zA-Z0-9_\-\.~]{4,}@[a-zA-Z0-9_\-\.~]{3,6}\.[a-zA-Z]{2,4}$"
Local $sString = "info@bvo.global" & @CRLF & _
"foo..bar+ddddd@baz.com" & @CRLF & _
"" & @CRLF & _
"foo@bar.baz.com" & @CRLF & _
".foo@bar.baz.com" & @CRLF & _
"foo.@bar.baz.com" & @CRLF & _
"" & @CRLF & _
"foo-bar@baz.com" & @CRLF & _
"-foo-bar@baz.com" & @CRLF & _
"foo-bar-@baz.com" & @CRLF & _
"客服@买卖.商务" & @CRLF & _
"" & @CRLF & _
"foo@bar.baz" & @CRLF & _
"foo@.bar.baz" & @CRLF & _
"foo@bar.baz." & @CRLF & _
"" & @CRLF & _
"foo@bar.baz" & @CRLF & _
"foo@bar.ba" & @CRLF & _
"foo@bar.baz.quux" & @CRLF & _
"foo@bar.b" & @CRLF & _
"foo@bar.bazquux" & @CRLF & _
"" & @CRLF & _
"foo@031.33.7.255" & @CRLF & _
"42@255.255.255.255" & @CRLF & _
"42@199.1.1.1" & @CRLF & _
"42@256.255.255.255" & @CRLF & _
"" & @CRLF & _
"foo@63-character-long-domain-name-which-is-allowed-by-the-standards.com" & @CRLF & _
"foo@64character-long-domain-name-which-isnt-allowed-by-the-standards.com" & @CRLF & _
"" & @CRLF & _
"255-chà räçter-loñg-emà îl#%address!&with+-some_weird.!?character~combinations'in_it-just-to-fill-üp-the-address-léngth-to-get-to-the-255-character.limit.-This_is_really_starting_to_become_a_quite_long_email_address.-who_would_even_use_something_like_this?@foo.bar" & @CRLF & _
"short-address-with-illegal-character,in-it@foo.bar" & @CRLF & _
"256-character-long.-email#%address!&with+-some_weird.!?character~combinations'in_it-just-to-fill-up-the-address-length-to-get-to-the-255-character.limit.-This_is_really_starting_to_become_a_quite_long_email_address.-who_would_even_use_something_like_this?@foo.bar" & @CRLF & _
"" & @CRLF & _
"foo@similarly-long-address-url.of-253-characters.long.which-is-still-allowed.within-the-standards.so-lets-just-fill-the-rest.of-this-253-character-long-address-with-lorem-ipsum.copypasta-filler-then.Lorem-ipsum-dolor-sit-amet.consectetur-adipiscing-elit.com" & @CRLF & _
"foo@similarly-long-address-urls.of-254-characters.long.which-is-not-allowed.within-the-standards.so-lets-just-fill-the-rest.of-this-254-character-long-address-with-lorem-ipsum.copy-pasta-fillers-then.Lorem-ipsum-dolor-sit-amet.consectetur-adipiscing-elit.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")