use strict;
my $str = 'info@bvo.global
foo..bar+ddddd@baz.com
foo@bar.baz.com
.foo@bar.baz.com
foo.@bar.baz.com
foo-bar@baz.com
-foo-bar@baz.com
foo-bar-@baz.com
客服@买卖.商务
foo@bar.baz
foo@.bar.baz
foo@bar.baz.
foo@bar.baz
foo@bar.ba
foo@bar.baz.quux
foo@bar.b
foo@bar.bazquux
foo@031.33.7.255
42@255.255.255.255
42@199.1.1.1
42@256.255.255.255
foo@63-character-long-domain-name-which-is-allowed-by-the-standards.com
foo@64character-long-domain-name-which-isnt-allowed-by-the-standards.com
255-chà räçter-loñg-emà îl#%address!&with+-some_weird.!?character~combinations\'in_it-just-to-fill-üp-the-address-léngth-to-get-to-the-255-character.limit.-This_is_really_starting_to_become_a_quite_long_email_address.-who_would_even_use_something_like_this?@foo.bar
short-address-with-illegal-character,in-it@foo.bar
256-character-long.-email#%address!&with+-some_weird.!?character~combinations\'in_it-just-to-fill-up-the-address-length-to-get-to-the-255-character.limit.-This_is_really_starting_to_become_a_quite_long_email_address.-who_would_even_use_something_like_this?@foo.bar
foo@similarly-long-address-url.of-253-characters.long.which-is-still-allowed.within-the-standards.so-lets-just-fill-the-rest.of-this-253-character-long-address-with-lorem-ipsum.copypasta-filler-then.Lorem-ipsum-dolor-sit-amet.consectetur-adipiscing-elit.com
foo@similarly-long-address-urls.of-254-characters.long.which-is-not-allowed.within-the-standards.so-lets-just-fill-the-rest.of-this-254-character-long-address-with-lorem-ipsum.copy-pasta-fillers-then.Lorem-ipsum-dolor-sit-amet.consectetur-adipiscing-elit.com';
my $regex = qr/^[a-zA-Z0-9_\-\.~]{4,}@[a-zA-Z0-9_\-\.~]{3,6}\.[a-zA-Z]{2,4}$/imp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}