const regex = /^[a-zA-Z0-9_\-\.~]{4,}@[a-zA-Z0-9_\-\.~]{3,6}\.[a-zA-Z]{2,4}$/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-zA-Z0-9_\\-\\.~]{4,}@[a-zA-Z0-9_\\-\\.~]{3,6}\\.[a-zA-Z]{2,4}$', 'gim')
const str = `info@bvo.global
foo..bar+ddddd@baz.com
foo@bar.baz.com
.foo@bar.baz.com
foo.@bar.baz.com
foo-bar@baz.com
-foo-bar@baz.com
foo-bar-@baz.com
客服@买卖.商务
foo@bar.baz
foo@.bar.baz
foo@bar.baz.
foo@bar.baz
foo@bar.ba
foo@bar.baz.quux
foo@bar.b
foo@bar.bazquux
foo@031.33.7.255
42@255.255.255.255
42@199.1.1.1
42@256.255.255.255
foo@63-character-long-domain-name-which-is-allowed-by-the-standards.com
foo@64character-long-domain-name-which-isnt-allowed-by-the-standards.com
255-chà räçter-loñg-emà îl#%address!&with+-some_weird.!?character~combinations'in_it-just-to-fill-üp-the-address-léngth-to-get-to-the-255-character.limit.-This_is_really_starting_to_become_a_quite_long_email_address.-who_would_even_use_something_like_this?@foo.bar
short-address-with-illegal-character,in-it@foo.bar
256-character-long.-email#%address!&with+-some_weird.!?character~combinations'in_it-just-to-fill-up-the-address-length-to-get-to-the-255-character.limit.-This_is_really_starting_to_become_a_quite_long_email_address.-who_would_even_use_something_like_this?@foo.bar
foo@similarly-long-address-url.of-253-characters.long.which-is-still-allowed.within-the-standards.so-lets-just-fill-the-rest.of-this-253-character-long-address-with-lorem-ipsum.copypasta-filler-then.Lorem-ipsum-dolor-sit-amet.consectetur-adipiscing-elit.com
foo@similarly-long-address-urls.of-254-characters.long.which-is-not-allowed.within-the-standards.so-lets-just-fill-the-rest.of-this-254-character-long-address-with-lorem-ipsum.copy-pasta-fillers-then.Lorem-ipsum-dolor-sit-amet.consectetur-adipiscing-elit.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}