package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([A-Ea-e0-9]{8})`)
var str = `,,aaaaaaaa,dddddddd,,e22221111,,22221111,,,22222222,,`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}