re = /([A-Ea-e0-9]{8})/
str = ',,aaaaaaaa,dddddddd,,e22221111,,22221111,,,22222222,,'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end