package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[attr#id]#content#`)
var str = `(?P<attr>\[[^]]+\])*(?P<mark>[*_\`#~^ˆ])(?P<text>.*?)(?P=mark)(?P<tail>[^[*_\`#~^ˆ]*)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}