$re = '/[attr#id]#content#/';
$str = '(?P<attr>\\[[^]]+\\])*(?P<mark>[*_`#~^ˆ])(?P<text>.*?)(?P=mark)(?P<tail>[^[*_`#~^ˆ]*)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);