const regex = new RegExp('[attr#id]#content#', 'g')
const str = `(?P<attr>\\[[^]]+\\])*(?P<mark>[*_\`#~^ˆ])(?P<text>.*?)(?P=mark)(?P<tail>[^[*_\`#~^ˆ]*)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}