import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
    public static void main(String[] args) {
        final String regex = "(^[^\\n\"]*\"[^\"\\n]*)\\n((?1))";
        final String string = "090033ec82b13639,CPDM Initiated,Logistical,\"There corrected.\",Gul Y Serbest,Urology\n"
	 + "090033ec82ae0c07,Initiated,NA,\"To   local testing\n"
	 + "Rohit  3 to 4.\",Julienne B Orr,Oncology\n"
	 + "090033ec82b35fd0,Externally Initiated,NA,regulatory agency requests,Kenneth A Lord,Oncology";
        final String subst = "\\1 \\2";
        
        final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
        final Matcher matcher = pattern.matcher(string);
        
        // The substituted value will be contained in the result variable
        final String result = matcher.replaceAll(subst);
        
        System.out.println("Substitution result: " + result);
    }
}