const regex = /(^[^\n"]*"[^"\n]*)\n((?1))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^[^\\n"]*"[^"\\n]*)\\n((?1))', 'gm')
const str = `090033ec82b13639,CPDM Initiated,Logistical,"There corrected.",Gul Y Serbest,Urology
090033ec82ae0c07,Initiated,NA,"To local testing
Rohit 3 to 4.",Julienne B Orr,Oncology
090033ec82b35fd0,Externally Initiated,NA,regulatory agency requests,Kenneth A Lord,Oncology`;
const subst = `\1 \2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);