// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(^[^\n"]*"[^"\n]*)\n((?1))"#).unwrap();
let string = "090033ec82b13639,CPDM Initiated,Logistical,\"There corrected.\",Gul Y Serbest,Urology
090033ec82ae0c07,Initiated,NA,\"To local testing
Rohit 3 to 4.\",Julienne B Orr,Oncology
090033ec82b35fd0,Externally Initiated,NA,regulatory agency requests,Kenneth A Lord,Oncology";
let substitution = "\\1 \\2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}