#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\[[^]]*?keyword=([0-9.]+)[^]]*]|\[[^]]*]"
Local $sString = "(1:[&a={1sa},s=3,keyword=0.1,qwsz={a}]:0.1)[s=2;p]:2:[s=3, keyword=9.23]"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)