$re = '/\[[^]]*?keyword=([0-9.]+)[^]]*]|\[[^]]*]/';
$str = '(1:[&a={1sa},s=3,keyword=0.1,qwsz={a}]:0.1)[s=2;p]:2:[s=3, keyword=9.23]';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;