const regex = /\[[^]]*?keyword=([0-9.]+)[^]]*]|\[[^]]*]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[[^]]*?keyword=([0-9.]+)[^]]*]|\\[[^]]*]', 'g')
const str = `(1:[&a={1sa},s=3,keyword=0.1,qwsz={a}]:0.1)[s=2;p]:2:[s=3, keyword=9.23]`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);