#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\+.*$"
Local $sString = "+StartsWithPlus" & @CRLF & _
"DoesNotStartWithPlus" & @CRLF & _
"HasPlus+ButDoesNotStartWithPlus"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")