re = /^\+.*$/m
str = '+StartsWithPlus
DoesNotStartWithPlus
HasPlus+ButDoesNotStartWithPlus'
# Print the match result
str.match(re) do |match|
puts match.to_s
end