package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\+.*$`)
var str = `+StartsWithPlus
DoesNotStartWithPlus
HasPlus+ButDoesNotStartWithPlus`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}