using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(:?(\+)|(00))?(:?966)?+(5|05)([503649187])([0-9]{7})$";
string input = @"+966555002871
00966555002871
0555339634
966555002871
05555557896";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}