$re = '/^(:?(\+)|(00))?(:?966)?+(5|05)([503649187])([0-9]{7})$/m';
$str = '+966555002871
00966555002871
0555339634
966555002871
05555557896';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);