import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(:?(\\+)|(00))?(:?966)?+(5|05)([503649187])([0-9]{7})$";
final String string = "+966555002871\n"
+ "00966555002871\n"
+ "0555339634\n"
+ "966555002871\n"
+ "05555557896";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}